P0107 fault

Results 1 to 2 of 2
  1. #1
    Theory Test Pass
    Join Date
    Jun 2020
    Location
    Scotland
    Car
    R53 JCW
    Posts
    9
    Recently rebuilt the top end of my R53 S engine. Head gasket, Water pump, charger service, timing chain, etc etc.
    built back up and car throwing a P0107 - Manifold absolute pressure or barometric pressure circuit low input. Engine light and dsc light also illuminated.

    Checked all the vac lines etc, seem ok. No reading from MAP sensors on obd scanner, visually checked both TMAP and MAP sensors which seem ok. Tmap slightly dirty. Checked power to both sensors, also ok. Could one or both sensors be at fault? No problems before work carried out so very confused why one or both would have packed in. Anyone had similar issues?

  2. #2
    Site Owner badwolf340's Avatar
    Join Date
    Sep 2006
    Location
    Scottish Borders
    Car
    X3 M competition,F56 GP ,F54 JCW white silver edtionTrafic Formula Edition
    Posts
    4,242
    Not had similar experiences but are connections clean and tight ? Try when running to see if there are air air leaks ,spray brake cleaner or similar when running and see if revs increase
    The cars in front are New MINI Scotland

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Follow Us
About us
You'll find details of our packed social calendar including MINI Runs, organised car shows, meet-ups for munchies, and other social events. There's also a wealth of information on the three latest generations of the new MINI from BMW, including owners pictures, common fault fixes, "how-to's", owner reviews and a bucket load of advice for all new MINI owners. Whether you have one of the first MINI's from the early 2000's, a second generation R56, or are planning a purchase of a nice shiny new F series, whether your car is a MINI One, a Cooper, Cooper S, JCW or a GP, THIS is the web site for you!